ntpd problems

Shelby Westman shelby.westman at gmail.com
Sat Oct 22 08:54:53 PDT 2005

Hello, all,

I am a relatively new freeBSD user. The problem I describe below happens on
both a 5.4 install and a 6.0 RC1 install.

Right after installing the OS, I enable ntpd in rc.conf, and setup a simple
config file in /etc/ntp.conf. When I reboot, I get this message:

Oct 22 10:40:57 alter ntpd[392]: ntpd 4.2.0-a Sun Oct 9 18:33:33 UTC 2005
Oct 22 10:40:57 alter ntpd[392]: bind() fd 6, family 28, port 123, addr
fe80:1::202:55ff:fe58:2957, in6_is_addr_multicast=0 flags=0 fails: Can't
assign requested address

Then ntpd does not synchronize the time. I set the clock manually (using
date) five minutes ahead to check and in fact it does not get adjusted.

I have tried all sorts of things. I tried assigning numeric addresses rather
than host names in the config file. I tried enabling ipv6 in sysinstall.
This machine does have a good route to the internet - I can use nslookup to
resolve host names, so I know the networking is working.

Below I have quoted the ntp.conf. The log file is empty - nothing is being
written there.

Does anyone have any ideas? I am stumped... thanks for your help.



config file as it stands now...

logfile /var/log/ntpd.log

# deny-by-default policy
restrict default ignore

#server -4 ntp-2.ece.cmu.edu <http://ntp-2.ece.cmu.edu>
#server -4 ticker.cis.sac.accd.edu <http://ticker.cis.sac.accd.edu>
#server -4 lain.ziaspace.com <http://lain.ziaspace.com>
#server -4 ntp1.linuxmedialabs.com <http://ntp1.linuxmedialabs.com>
server <>

driftfile /var/spool/ntp.drift

More information about the freebsd-questions mailing list