Steve Bertrand steve at ibctech.ca
Wed Nov 16 19:27:24 GMT 2005


> -----Original Message-----
> From: owner-freebsd-questions at freebsd.org 
> [mailto:owner-freebsd-questions at freebsd.org] On Behalf Of 
> Steve Bertrand
> Sent: Wednesday, November 16, 2005 1:58 PM
> To: 'Chuck Swiger'
> Cc: 'FreeBSD Questions'
> Subject: RE: ICH6-R
> > > - During install (this time it's 6.0-RELEASE as of Nov. 3),
> > I have 3
> > > selections to select from when FDISKing etc: ad4, ad6 and ar0.
> > > 
> > > - I select ad0 to configure as this is the bootable RAID 
> volume, and
> >               ^^^ ...?
> > > everything installs perfectly fine. I then proceed to
> > reboot the box,
> > > and a blinking cursor appears in the top-left side of the
> > screen, as
> > > if BSD wants to boot, but nothing ever happens.
> > 
> > If you've configured or enabled a RAID setup in the BIOS, then ar0 
> > ought to be the device you should use.
> Yes, I have RAID-1 configured in the BIOS for SATA drives. My 
> other servers (using either Promise cards, or software RAID 
> on IDE) are all ar0, so I figured this would be right/
> > If you are trying to install to a drive in normal, non-RAID 
> mode, then 
> > ad0 (if you have it) would be the choice.  If you've got static ATA 
> > numbering enabled in the kernel and you've got no parallel 
> ATA devices 
> > attached, only SATA, then
> > ad4 might be right.
> All drives are SATA, not PATA. I have tried to boot off of 
> ad4, and ad6 respectively to no avail. I'm going to try one 
> more install disabling RAID and popping out one of the 2 SATA 
> drives in the system to see if that will work, although I'm 
> certain I've tried that before.

Ok, I've made it a little farther now. I booted off the CD and went
straight to the loader prompt. I then unloaded the CD's kernel, and did:

# load disk1s1a:/boot/kernel/kernel
# boot

It then dropped me into the mountroot> prompt, in which I typed:

# ufs:ad4s1a

...and up it came. So, I can get the machine running, but only if I
manually load the proper kernel, then manually specify the root device.
I verified that /etc/fstab shows the proper file systems to be mounted.

Apparently, either this is caused by the PC not actually pointing to the
boot device I tell it to in BIOS, or no remnants of FBSD are being found
on the disk.

At least now I know that it *can* work, I just have to figure out how to
get it to come up itself ;)


More information about the freebsd-questions mailing list