Can't play CD / mount CDROM

Jerry McAllister jerrymc at
Wed May 4 06:22:26 PDT 2005

> Hey Toomas,
> In followup to my prev. reply and your question.
> Here is the output of the command: 'grep acd0 /var/run/dmesg.boot'
> acd0: CDROM <Compaq CRD-8322B/1.03> at ata0-slave PIO4
> Thanks.
> PS: Kent, your suggestion is what I have already tried ...I've tried to 
> 'umount /cdrom' it doesn't do anything.... since BSD cannot find it... when 
> I go in /dev I do not see /cdrom there is only acd0, However when I try 
> mkdir cdrom under /dev it says it already exists...? ls -a doesn't show 
> anything. The intelligence behind the O/S is what amazes

I haven't been following this thread so I may be jumping in out of
order, but a comment on this post.

You would not do a mkdir of anything in /dev.   
That directory is a special one for devices.   acd0 is a device,
for example.   You want to mount this device to a mount point.
To make a /cdrom mount mount, 
you would probably want to do mkdir cdrom in root, eg.
   cd /
   mkdir cdrom

Then do something like mount /dev/acd0 /cdrom
or probably more like:

   mount_cd9660 /dev/acd0c /cdrom

But, that is for looking at files in a file system way.
Probably, for sound, you don't want to mount the cd at all.
I had sound in a FreeBSD a long time ago, but haven't
bothered in several years with more recent version.   So things
may well have changed.

I believe you do still need to have your kernel built with 'device  snd'.
Check in:  /usr/src/sys/i386/conf/LINT
or its equivalent (I don't have a handy at the moment to look at).


> >From: Toomas Aas <toomas.aas at>
> >To: Michael Neeff <cool_mike_21 at>
> >CC: questions at
> >Subject: Re: Can't play  CD / mount CDROM
> >Date: Mon, 02 May 2005 23:23:13 +0300
> >
> >Hi Michael!
> >
> >I was hoping someone can give you a more definite answer, but it seems 
> >no-one knowledgeable has responded, so here are my comments, worth exactly 
> >what you paid for them :)
> >
> >>I've been trying since the past couple of days to get my sound back... it 
> >>all started when I followed the steps from the manual in setting up 
> >>statically sound drivers for my old Compaq DeskPro EN series...for FreeBSD 
> >>5.3. I included the "snd_sbc" driver, since when I kldload snd_driver it 
> >>comes up as ESS 1869 in my kernel file (MYKERNEL).. I also included the 
> >>line "device sound" in the MYKERNEL (customized kernel Chp. 7) for some 
> >>reason it doesn't work when I want to run mpg123...
> >
> >The above stuff seems roughly correct. That's how I built sound into kernel 
> >on my home PC, but I'm not at that PC now so I can't check my kernel 
> >config.
> >
> >What do you mean by "it doesn't work"? Do you get an error message? Or 
> >simply nothing happens? In the latter case, check your mixer settings, 
> >speaker volume knob and physical connections.
> >
> >After building sound into kernel, you can also remove the relevant module 
> >loading lines from /boot/loader.conf, but I think that even if you left 
> >them in it shouldn't prevent sound from working - you would just get an 
> >error message saying something to the tune of "file already exists", 
> >meaning that the functionality for which you are trying to load the module 
> >is already included in the kernel.
> >
> >>...Anyways this is the least of my problems. I now comment the lines: 
> >>device snd_sbc, device sound recomplie the kernel and keep getting cd9660: 
> >>device /dev/acd0 Input/Ouput error when I try to mount any of my CDs... 
> >>(music or data)
> >
> >You shouldn't try to mount music CDs since they don't contain any 
> >filesystem that can be mounted. The error message above is exactly what you 
> >get when you try to mount an audio CD. Mounting data CDs should work, 
> >though.
> >
> >Does the command 'grep acd0 /var/run/dmesg.boot' contain any text?
> >
> >>I've tried : mount -t cd9660 /dev/acd0 /cdrom and several other 
> >>combinations :
> >>mount cd9660 /dev/acd0 /cdrom; mount cd9660; mount_cd9660 /dev/acd0 
> >>/cdrom; mount /cdrom  - still the same thing...
> >
> >At least *some* of the above commands should work ;-)
> >
> >>I even tried loading my old kernel (GENERIC)  from /boot/kernel.old/kernel 
> >>(Btw, is this the same as the last recompile of MYKERNE?L... I think I 
> >>have compiled 3/4 times by now in the hopes that this would work)
> >
> >Yes, every time you build an install new kernel, the previous kernel is 
> >copied to kernel.old and previous kernel.old is wiped out. So it is well 
> >possible that you don't even have the original kernel with which things 
> >worked on your system any more.
> >
> >>HELP - I'm a newbie... I've got almost everything working with KDE 
> >>3.3...and now back to this. I was so happy when I could run cdcontrol from 
> >>the command line and now I'm :o( frustrated !!
> >
> >One more thing you could try is to get the GENERIC kernel from e.g. 
> >installation CDs and boot with that.
> >
> >--
> >Toomas Aas --------------------------------------------------------
> >|arvutivõrgu peaspetsialist | head specialist on computer networks|
> >|Tartu Linnakantselei       | Tartu City Office                   |
> >----------------------------------------------------- +372 736 1274
> >
> >
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list