Wireless Keyboard/Mouse setup

Louis LeBlanc FreeBSD at keyslapper.net
Wed Mar 23 17:06:00 PST 2005

Hey folks.

I'm back with an Xorg config question - but in this case, it does
apply specifically to FreeBSD.

I have one of those new wireless keyboards - you all know that little
hardware company in Redmond that thinks it can write software too?

Well, this is the "Microsoft Wireless Optical Desktop" (Pro).  And the
keyboard works great (mostly), but I can't seem to get the mouse
working.  I am running FreeBSD 5.3 RELEASE-p3 and Xorg 6.8.2.

I have tried all the configs recommended by
/usr/X11R6/lib/X11/doc/README.mouse, which mentions this mouse
specifically (the IntelliMouse Explorer).

What that doc says, is:
To use this mouse as the PS/2 device and the OS supports PS/2 mouse

          Option    "Protocol"     "ExplorerPS/2"

But that doesn't work, so I assume PS/2 initialization is not supported . . .

It also says:
To use this mouse as the USB device and the OS supports the generic
HID protocol:

          Option    "Protocol"     "usb"

To use this mouse as the USB device and the OS supports automatic
mouse detection:

          Option    "Protocol"     "Auto"

Now, I am pretty sure - but I could be wrong - that FreeBSD DOES
support automatic mouse detection, but I don't know if it supports the
HID protocol.  Either way, neither option works.

The mouse in question is pretty reliably routed to /dev/ums1 and is
detected correctly in /var/log/messages:
Mar 23 19:24:48 keyslapper kernel: ums1: Microsoft Microsoft Wireless Optical Desktop® 1.00, rev 2.00/73.73, addr 3, iclass 3/1
Mar 23 19:24:48 keyslapper kernel: ums1: 5 buttons

I have turned off the automatic moused spawn by usbd, because I also
have a trackball that is used from /dev/usm0 - and it works perfectly.

This is the current mouse config from /etc/X11R6/xorg.conf:
Section "InputDevice"
        Identifier  "Mouse"
        Driver      "mouse"
        # Option      "Protocol" "Auto"
        Option      "Protocol" "usb"
        Option      "Device" "/dev/ums1"
        Option      "Buttons"      "7"
        Option      "ZAxisMapping" "6 7"

I have tried Auto and usb as the protocol, neither work.  This is the
mouse with the wheel that is also supposed to shift left or right for
whatever reason and the two extra small thumb buttons on the left, but
I'll be happy with getting just the regular 3 buttons working.

Google has turned up no detail on this keyboard/mouse combo and Xorg

Anyone have any idea?

If you have this working, I'd be grateful for a mouse config section,
and if you are able to get all the "special" keys working, I'd be
interested in what you did to get them recognized - xev doesn't seem
to get signals from them.

Louis LeBlanc                          FreeBSD-at-keyslapper-DOT-net
Fully Funded Hobbyist,                   KeySlapper Extrordinaire :)
Please send off-list email to:         leblanc at keyslapper d.t net
Key fingerprint = C5E7 4762 F071 CE3B ED51  4FB8 AF85 A2FE 80C8 D9A2

Writing is turning one's worst moments into money.
    -- J.P. Donleavy

More information about the freebsd-questions mailing list