unionfs double mount reboots the system on 5.3-STABLE

Artem Koltsov Artem.Koltsov at wfinet.com
Tue Mar 15 15:30:47 PST 2005

I tried to build jails on top of one distribution and found the following problem.

How to repeat:


mkdir test
cd test
mkdir a
mkdir a-ro
mkdir a-ro-rw
echo "aaaa" >> a/file1
mount -v -t unionfs -o ro ~/test/a ~/test/a-ro
mount -v -t unionfs -o -b ~/test/a-ro ~/test/a-ro-rw
vi a-ro-rw/file1   ##### <<<<<<< will reboot here

mount before reboot:
<above>:/root/test/a on /root/test/a-ro (unionfs, local, read-only, noclusterw)
<below>:/root/test/a-ro on /root/test/a-ro-rw (unionfs, noclusterw)

uname -a
FreeBSD local.local.internal 5.3-STABLE FreeBSD 5.3-STABLE #14: Sat Feb 26 19:09:37 EST 2005     root at local.local.internal:/usr/obj/usr/src/sys/CUSTOM  i386

Can anyone repeat it and let me know if you have the same result? Any suggestions what it could be?


Artem Koltsov
Resource Management
Wireless Facilities, Inc.

Any views expressed in this message are those of the individual sender, except where the message states otherwise and the sender is authorized to state them to be the views of any such entity. The information contained in this message and or attachments is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material.  If you received this in error, please contact the sender and delete the material from any system and destroy any copies.

More information about the freebsd-questions mailing list