Problems stopping pptp...

Eric Schuele e.schuele at
Fri Mar 11 09:53:15 PST 2005


I have some keybindings on my laptop that allow me to easily start and 
stop a pptp connection to my office.

It looks something like:
   Control Shift V opens the vpn using
      sudo pptp x.x.x.x OFFICE
   Alt Shift V closes the connection
      sudo killall -TERM ppp

When I do this (stopping pptp) I get a pptp.core in my home dir.  In 
fact no matter what I try... I allways end up with a core.

I have tried:
   # as myself
   sudo killall -TERM ppp
   sudo kill -TERM `cat /var/run/`
   sudo killall -TERM pptp
Also tried those as root (without sudo).
I have tried all of the above after issuing the pptp command from CLI as 
root.  Still no luck

I have also tried other signals (QUIT, ABRT).

So... the question is.. How am I supposed to shut down a pptp 
connection?  I would like to be able to do it with sudo, or at least 
some way to bind it to keys of non-root users.



More information about the freebsd-questions mailing list