Compiling XFE

Ramiro Aceves ea1abz at
Mon Mar 7 05:49:36 PST 2005

Graham Bentley wrote:
> Hello All,
> I admit, I am a lazy admin and like clicking with a mouse
> whilst talking on the phone, drinking tea and eating toast.
> I got used to XFE from using Linux and have enjoyed it in
> FreeBSD - until I installed it under 5.3

I am also an XFE fan, I love the command line also, but XFE is very 
useful for browsing the directories and making massive copying of files.

> Now it core dumps for no reason whatsoever. At any time.
> My installation was package originally so I updated ports
> and compiled XFE - but no difference - it still bombs out.

I have just updated the ports collection and tried to compile XFE but is 
is marked as broken:

#make install clean
xfe-0.72_1 is marked as broken: Does not build with current fox-devel 

Update your ports collection and you will get the same error as mine. 
(Before updating the ports collection I had the same error as yours)

I think is is a matter of waiting for them to fix it.

I have tried to fix the makefile but I am not an expert and I abandoned.


> So I figure I would like to try compiling from the latest
> source from the XFE site on sourceforge. The forum explicitly
> says you need Fox 1.2 and wont work with anythig else
> (I had 1.4 so I de-installed and DL / made version 1.2
> - which BTW comes with quite a useable and stable
> FM called PathFinder as well as a competent editor)
> So with my Fox 1.2 installation made installed I came to
> make XFE which now reports ;
> checking for fxfindfox in -lFOX-1.2 ... no !
> configure error: "libFOX not found"
> I googled on this and found some stuff relating to the
> wrong version of the Fox libraries and also some people
> who have the same problem as me but the bottom drops
> off those threads with no answers :(
> Can anyone point me in the right direction ?
> Thanks!

More information about the freebsd-questions mailing list