DHCP3 Server on FreeBSD 4.11

Paul Taylor ptaylor at addressplus.net
Sun Jul 24 12:57:05 GMT 2005


Thanks for the suggestions, but I'm still coming up with the same  
failure...  You said that it built for you - Are you on FreeBSD 4.11,  
or a newer build of FreeBSD?

I ask because the maintainer of this port stated in this post (http:// 
that he didn't have a FreeBSD 4.11 box to test on and that that  
particular user's problem was related specifically to 4.11.

I'm actually doing this to try to create a monowall development box,  
which uses 4.11 as a base system.  My FreeBSD box is actually a VM.   
We need to be able to create our own special builds of monowall to  
add at least one new feature.  The way things usually work is that  
one real reason starts us tinkering, then many additional features  
are suddenly "needed" once management realizes that we can add  
them...  :)


On Jul 24, 2005, at 3:42 AM, Glenn Dawson wrote:

> At 08:51 PM 7/23/2005, Paul Taylor wrote:
>> Hi,
>> I'm new to FreeBSD, so there is a good possibility that this is just
>> something stupid that I'm doing wrong...  I've had bad timing with
>> linux software that I've tried installing in the past (just happened
>> to try to install while there was a broken distribution, etc.) and
>> I'm starting to think that is my situation here...
>> I'm trying to install the ports version of isc-dhcp3-server...
>> According to what I've read, it should be as simple as:
>> cd /usr/ports/net/isc-dhcp3-server
>> make
>> (Set options in the dialog box, in my case unselect everything, then
>> let it run the config, make, etc.)
>> install -s work/dhcp-*/work.freebsd/server/dhcpd /usr/local/sbin
>> Now, my problem starts with the make...  When I run it, this is what
>> I get:
>> # make
>> ===>  Vulnerability check disabled, database not found
>> ===>  Found saved configuration for isc-dhcp3-server-3.0.2_8
>> => dhcp-3.0.2.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
>> => Attempting to fetch from ftp://ftp.isc.org/isc/dhcp/.
>> fetch: ftp://ftp.isc.org/isc/dhcp/dhcp-3.0.2.tar.gz: File unavailable
>> (e.g., file not found, no access)
>> => Attempting to fetch from ftp://ftp.isc.org/isc/dhcp/dhcp-3.0-  
>> history/.
>> dhcp-3.0.2.tar.gz                             100% of  833 kB  408  
>> kBps
>> ===>  Extracting for isc-dhcp3-server-3.0.2_8
>> => Checksum OK for dhcp-3.0.2.tar.gz.
>> ===>  Patching for isc-dhcp3-server-3.0.2_8
>> ===>  Configuring for isc-dhcp3-server-3.0.2_8
>> Unexpected argument: server
>> System Type: --subsys
>> No build directory for freebsd - please run ./configure.
>> ===>  Building for isc-dhcp3-server-3.0.2_8
>> make: don't know how to make all.server. Stop
>> *** Error code 2
>> Stop in /usr/ports/net/isc-dhcp3-server.
>> So, it looks like it works correctly up until the Configure  
>> section...
>> This output:
>> Unexpected argument: server
>> System Type: --subsys
>> No build directory for freebsd - please run ./configure.
>> is from the Configure script, in the /usr/ports/net/isc-dhcp3- 
>> server/ work/dhcp-3.0.2 directory...  It doesn't appear to be  
>> expecting the
>> "--subsys server" that is passed.
>> Now, I ran a "make -n" to get the actual commands that it is issuing,
>> and it does appear to be running "./configure --subsys server" and I
>> also noticed that the last make it runs is: "make -f Makefile
>> all.server".  That probably explains the "make: don't know how to
>> make all.server. Stop" error...
>> Now, the real question is how to I fix this?  Am I missing some sort
>> of environment variable?  Is this port broken?
>> Also, note that I have tried manually running ./configure and
>> performing a "make all"...  But I get this far in the make, then:
>> make: don't know how to make omshell.c. Stop
>> *** Error code 1
>> Stop in /usr/ports/net/isc-dhcp3-server/work/dhcp-3.0.2/work.freebsd.
>> *** Error code 1
>> Stop in /usr/ports/net/isc-dhcp3-server/work/dhcp-3.0.2.
>> So, I'm hoping someone out there can assist me...
> I just built the same port with the same options, and it built  
> without error, so I don't think the port is broken.
> I did notice this line in your output:
> Found saved configuration for isc-dhcp3-server-3.0.2_8
> which would indicate that it is using options from a previous  
> install.  You might want to do a make clean in the ports dir, then  
> rm -R /var/db/ports/isc-dhcp3-server to get rid of the old config.   
> Then try a make install and see if builds correctly.
> -Glenn
>> Thanks,
>> Paul
>> _______________________________________________
>> freebsd-questions at freebsd.org mailing list
>> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>> To unsubscribe, send any mail to "freebsd-questions- 
>> unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list