FreeBSD 5.4 & Adaptec 2010s - raidutil / aaccli

M. L. user at
Sat Jul 16 16:45:56 GMT 2005


I've managed to install FreeBSD 5 on a RAID-10 after my weird problem of 
random letters/numbers scrolling on the screen upon a CD boot (actually 
installed 4.10 from CD, cvsupped to 5.4, it worked - seems to be 
something related to the CD boot loader..).

Wanting to have something to manage the raid with, a simple make search 
key=adaptec showed asr-utils and aaccli. I've had no luck with either one.

I don't have the server online now (have it at home before shipping it, 
only have one set of cables, a pain to switch them due to cable 
locations etc)

With raidutil (from asr-utils), a raidutil -L all says something about 
COMPATIBITY NUMBER and then something about /dev/rdpti17. I've tried to 
symlink /dev/asr0 to /dev/rdpti17, but the symlink is gone when I run 
raidutil again. I googled a bit and there were suggestions about 
/dev/rasr0 -> /dev/rdpti17, but I have no rasr0 device - only asr0. 
There was also some links about increasing SYSV memory, which I did, no 
luck either.

I tried aaccli after having no luck with raidutil, and a aaccli open 
asr0 says the controller is invalid or non-existant.

camcontrol devlist shows the RAID-10, and I'm pretty sure the RAID is 
working - I've installed FreeBSD on it lol :-)

All that I'm missing now is a tool to be able to manage the raid..  any 
suggestions ?

More information about the freebsd-questions mailing list