fdisk/bsdlabel: cannot write to disk

Jan Christian Meyer janchris at stud.ntnu.no
Tue Jan 25 01:31:49 PST 2005

On Tue, 25 Jan 2005, Norbert Koch wrote:
> Sysinstall reported that it cannot write to the hard disk.
> Next I only tried to create a new partition inside an
> existing slice. The same again. I tried the same manually
> with fdisk/bsdlabel and the same happens. I tried it in
> single user mode and even booted FREESBIE. Always the same
> problem.
> I must be doing something simple very wrong.
> But what? What f*cking manual did I not read?

man atacontrol?

I don't know if your problem is the same as mine, but I recently
had a similar issue trying to partition a disk which came up in
UDMA100 mode; it wouldn't work until I forced it to UDMA66.

I think my problem came from the disk being attached with a
less-than-optimal cable, but I haven't researched it further, as
I don't need it to be particularly fast.

Just a suggestion, though - all standard disclaimers about
variations in your mileage apply.

Good luck,
 -Jan Christian

More information about the freebsd-questions mailing list