Problem with mknod for /dev/random => jailed bind configuration

bsd at bsd at
Tue Feb 8 06:38:33 PST 2005


I've tried to configure a bind server in a chroot jail and am facing a 
problem with /dev/random
Thaugh I've read the man mknod I have to say that this didn't help me 
in solving the problem.

When I start named with the -g switch here are the error.

> 08-Feb-2005 15:18:22.551 errno2result.c:109: unexpected error:
> 08-Feb-2005 15:18:22.551 unable to convert errno to isc_result: 6: 
> Device not configured
> 08-Feb-2005 15:18:22.551 could not open entropy source /dev/random: 
> unexpected error
> 08-Feb-2005 15:18:22.551 using pre-chroot entropy source /dev/random

I've used the following mknod command :

mknod /var/named/dev/null c 2 2
mknod /var/named/dev/random c 2 3

and also tried :

mknod random c 245 0
mknod null c 2 2

I've chmod 666 the two files and make shure they are owned by bind:bind 
// ??

Any help will be welcome.

Grégory Bernard       11, rue de la Tour
Directeur                 75116 Paris France         tel : +(33) 1 40 26 43 14
PGP ID --> 0x1BA3C2FD

"All parts should go together without forcing. You must remember that 
the parts you are reassembling were disassembled by you. Therefore, if 
you can't get them together again, there must be a reason. By all 
means, do not use hammer." -- IBM maintenance manual, 1975

More information about the freebsd-questions mailing list