Mozilla plugins broken after port upgrade

Chris Hill chris at
Thu Dec 29 19:38:26 PST 2005

Yesterday I cvsup'ed and upgraded my ports, using the procedure I've 
been using for quite some time. After it was done, most of my Mozilla 
plug-ins no longer work. I did not upgrade my operating system at that 
time, since I'm already at the latest patchlevel.

The specific issues are with acroread7, flash and mplayer-plugin. All of 
these worked as plug-ins before the upgrade, but now none of them do. 
Acroread7 and mplayer work fine in their standalone application 
incarnations, but not as plug-ins. Curiously, the java plug-in still 
works fine. In Mozilla, about:plugins shows java and the mplayer stuff, 
but not anything pertaining to Acrobat or PDFs.

Here is what I've done to try to fix this:

tripel# mv /etc/libmap.conf /etc/libmap.conf.old
tripel# cp 

/etc/libmap.conf - both the new and old versions - have an entry like
# Acrobat7 with Mozilla/Firebird/Galeon/Epiphany/Konqueror/Kazehakase
[/usr/compat/linux/usr/local/Adobe/Acrobat7.0/Browser/intellinux/]                       pluginwrapper/ exists; it's a symlink to, both in 
/usr/compat/linux/lib. However, the path shown in [square brackets] does 
not exist. Does it need to? man libc.conf doesn't say anything about 
those square bracket entries. On the off chance, I tried creating that 
heirarchy of directories and touch'ing, but no love so I got 
rid of it.

   $ ls /usr/local/lib/pluginwrapper

A search of the list archive turned up a post saying that you have to 
have linprocfs mounted *before* doing the *install* on 
linuxpluginwrapper. I made that happen; relevant df output is
   Filesystem  1K-blocks  Used  Avail Capacity  Mounted on
   linprocfs           4     4      0   100%    /usr/compat/linux/proc

I then deinstalled the following via 'make deinstall', then did 'make 
reinstall' in this order:

Question: Can someone point me to a writeup of what I need to do, in 
what order, to repair this?

Thanks very much.

$ uname -a
FreeBSD 5.4-RELEASE-p8 FreeBSD 5.4-RELEASE-p8 #0: 
Thu Oct 13 22:12:04 EDT 2005 
chris at i386

Chris Hill               chris at
**                     [ Busy Expunging <|> ]

More information about the freebsd-questions mailing list