Boot error

Giorgos Keramidas keramida at
Fri Dec 23 07:50:43 PST 2005

On 2005-12-23 15:20, rajoor <fbsd at> wrote:
>Giorgos Keramidas wrote:
>>On 2005-12-23 14:18, Ariane & Ron Joordens <joordens at> wrote:
>>> My FreeBSD 6.0 computer refuses to boot. It gets to the
>>> screen where it pauses for 10 seconds and gives you the
>>> choice of 8 boot options, and then...nothing!
>>> Choosing the default option shows a single line
>>> "/boot/kernel/acpi.ko text= etc,..." then the next line shows
>>> "|", and that's it. All the other boot options show just the
>>> "|" and that's it. I have waited for up to 30 minutes, but no
>>> change. The only way out is to reset the computer.
>>> Prior to this prblem the computer worked perfectly. FreeBSD
>>> 5.4 was installed about 4 months ago, this was upgraded to
>>> 6.0 about 2 months ago. Everything had been recompiled and I
>>> never had any problems, until this.
>>> I suspect that my 2 year old son has been pressing the power
>>> button repeatedly which may have caused this.
>> Do you still have the FreeBSD install CD-ROM?  You can use
>> that to boot.
>> Just make sure that the CD-ROM boots fine up to the sysinstall
>> menu.
>> If that works, then there's definitely something wrong with
>> the kernel or the other boot files you have on disk, and we'll
>> see what can be done.
> Thanks Giorgos,
> The install cd boots just fine. So I then looked up the manual
> and tried to boot from /boot/kernel.old.kernel but that doesn't
> work either.
> What can we do next?

You can try using the "Live CD" CD-ROM, to boot into the live
FreeBSD system and try to run fsck on the disk that's failing.

The live CD-ROM is disc2.iso from the release ISO images.  If you
have this CD-ROM, you can boot into sysinstall and choose:

    Fixit  =>  2 CDROM/DVD

You will then enter a shell that runs from the live CD-ROM, and
be able to run fsck(8) on your disks :-)

More information about the freebsd-questions mailing list