xhost problem

Matthew Seaman m.seaman at infracaninophile.co.uk
Sat Oct 30 10:39:53 PDT 2004

On Sat, Oct 30, 2004 at 10:50:01AM -0600, Gary Aitken wrote:
> I can't get an xterm from another machine to display on my 5.3 system.
> I've tried xhost with the ip of the machine I want to allow in,
> and finally tried xhost + to allow any machine in,
> but attempts to display still fail with "Can't open display w.x.y.z:0.0"
> firewall_enable and ipfilter_enable are NO at the moment,
> and the source (xterm) system is open on the internal network.
> What am I missing?

Xservers don't listen on the network by default nowadays, because
running X across the network in plain is about as bad as using rsh(1),
or unencrypted telnet(1).  Ideally you should be tunnelling the X
session through ssh(1) -- look for the description of the '-X' and
'-Y' flags to ssh ('-Y' is only available with more recent versions of
ssh(1)), and the 'ForwardX11' command you can use in
/etc/ssh/ssh_config or ~/.ssh/config.

If you're tunnelling through ssh(1), everything should be setup
automatically for you: your $DISPLAY on the remote machine will look
like 'localhost:10.0' or 'remote.host.name:10.0' -- don't fiddle with
the $DISPLAY setting, or you'll never get the forwarding to work.



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20041030/45105e4e/attachment.bin

More information about the freebsd-questions mailing list