Unable to find package files (was Re: help please)

Kevin D. Kinsey, DaleCo, S.P. kdk at daleco.biz
Mon Nov 15 12:50:58 PST 2004

Aaron Carranza wrote:

>I installed freebsd version 4.9, but for some reason I can't download any
>packages from any website, version 4.8 also gives me the same problem. Why
>is this happening?

Kevin Kinsey wrote:

Hi, Aaron:

We must assume from your post that you receive
an error message?  If so, what is it?

If you are receiving no message, please describe
the symptoms and your observations about the

Kevin Kinsey

Aaron Carranza wrote:

>Well, to begin with I installed 4.9 configure the network setting had access
>to the internet, but when I went into sysinstall to download the
>cvsup-without-gui, it did not work. I choose the ftp passive because I have
>a firewall in between then I was asked to choose a website, it says looking
>up host and the name of the site, but no connection is established and it
>goes back to the bsd configuration window. If I go to media again it asked
>me if I want to use the ftp info that I gave before I will choose no and I
>will display the different ftp sites and when I choose another one the same
>thing happen. I installed 4.8 and I had the same problem; however, when I
>installed 4.10, I had instant reply. I went to mirrors.rcn.com/pub and as I
>go through the site there is no iso images for 4.8 or 4.9 and the only 4.9
>that is there do not contain packages or ports only documentation plus some
>folder has a question mark on them. I also tried like installing the os over
>the internet but there is no download for 4.8 or 4.9 but for version 4.10 I
>could. I also tried from the command line typing:
>Pkg_add -r cvsup-without-gui-16.1h and I got the following message
>Error: FTP unable to get
>p-without-gui-16.1h.tbz: file unavailable (e.g., file not found, no access)
>Pkg_add unable to fetch. Then it gives the same path as above message and
>ends with, "by URL".
>Please help me thankyou.

If it were me, I would try this:

1. Install the ports tree (ignore this is /usr/ports is already populated).

$ sysinstall
Choose "Configure".
Choose "Distributions".
Choose "ports" and punch "OK" button.
Follow though the process.

2. Grab a new ports index.

$ make fetchindex

3. Try the package add again:

$pkg_add -r cvsup-without-gui-16.1h

This might or might not help, but it might be worth
a try. Somehow or another, pkg_add is looking for
packages that were put on the servers 18 months ago,
and it's not particularly surprising (to me*) that they're
not there any longer.

Kevin Kinsey

*now, I could be wrong in this, or maybe it's just a mistake.
4.8-RELEASE has been "extended" past its normal EOL, but
maybe they forgot to tell the FTP admin(s) ....

More information about the freebsd-questions mailing list