MYSQL startup error

Gareth Bailey freebsd at
Wed Mar 17 23:57:46 PST 2004

I am running 5.2 Release, and have recently installed mysql-4.0.18 server. I
first made a default install by issuing the following commands in the port:

$ make
# make install
$ cd /var/db/mysql && mysql_db_install

Worked perfectly when i started up with:
$ mysqld_safe &

Then i decided i wanted to reinstall with DB_DIR=/usr/db/mysql
I made deinstall and clean in the port. I removed the /var/db directory
manually. I then did the following in an attempt to install the DB_DIR in

# mkdir /usr/db/mysql
# chown -R mysql /usr/db
#chgrp -R mysql /usr/db
$ make DB_DIR=/usr/db/mysql
# make DB_DIR=/usr/db/mysql install

I encountered the following two problems:

1. Crontab complained with the following message:

"mkdir: /var/db/entropy: Permission denied
/usr/libexec/save-entropy[45954]: The entropy directory /var/db/entropy does
not exist, and cannot be created. Therefore no entropy can be saved."

I solved this by creating /var/db/entropy and chowned and chgrped to mysql
(don't know if that was right.)

2. I can't start mysqld_safe using command 'mysqld_safe &'. I get the
following errors...

 when i try as normal user:
"/usr/local/bin/mysqld_safe: cannot create /usr/db/mysql/server.err:
Permission denied"

when i try from  root:
"server# Starting mysqld daemon with databases from /usr/db/mysql
040318 09:51:58  mysqld ended"

I had a look at server.err in /usr/db/mysql and i found the following line:

"040318  9:51:56  Fatal error: Can't open privilege tables: Can't find file:
'./mysql/host.frm' (errno: 13)"

Please advise. Any assistance will be very much appreciated.
Thank you

More information about the freebsd-questions mailing list