Printing from Mac OS X to CUPS on FreeBSD 4.9-STABLE...

lists at lists at
Mon Mar 15 05:52:05 PST 2004

Okay. I've looked hi and lo for an answer to this and I'm not coming up 
with anything useful.

I have two machines on the same network (192.168.0.x). One is an x86 
running 4.9-STABLE and CUPS 1.1.19. The other is a PowerBook G4 running 
Mac OS X 10.3.2 (Panther). The x86 machine has an HP laser printer 
attached to it via parallel.

When on the fbsd machine, I can print files locally just fine. Under 
Mac OS X I can print to file as Postscript or PDF, put the file on the 
fbsd machine and print it locally just fine. So, it appears the PS/PDF 
data coming from OS X is not a problem. However, when I try to print 
from Mac OS X to the x86 box using IPP...nothing.

I was getting a "Destination printer does not exist!" in the error log. 
I believe I've turned on browsing locally (BTW, I appear to be 
receiving CUPS' broadcast packets). I've tried configuring IPP printing 
on the PowerBook using both the Printer Setup Utility and 
http://localhost:631/. No go.

Here's my cupsd.conf:

LogLevel info
RequestRoot /usr/local/var/spool/cups
ConfigFilePerm 0644
TempDir /usr/local/var/spool/cups/tmp
BrowseShortNames No
ImplicitClasses Off
RootCertDuration 43200
<Location />
Order Deny,Allow
Deny From All
Allow From
Allow From
<Location /admin>
AuthType None
AuthClass Anonymous
Order Deny,Allow
Deny From All
Allow From
Allow From

The error_log file on the fbsd box shows the following error:

	get_printer_attrs: resource name '/ipp' no good!

Does there need to exist an ipp directory under the spool directory? 
Where? I've tried this and still no go. Permissions, perhaps?



- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  Alexander Sendzimir (owner)                    802 863 5502
  MacTutor: Apple Mac OS X Consulting       info at

freebsd-questions at mailing list
To unsubscribe, send any mail to 
"freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list