Mounting a 4.5R FS during 5.2.1 installation

Alex de Kruijff freebsd at
Sun Mar 14 18:26:39 PST 2004

On Sat, Mar 13, 2004 at 10:56:34AM -0500, Charles Bacon wrote:
> Situation: An old remotherboarded PC, Tomato, has an old 4.5R
> on a 20GB disk.  I also have an unused 2940 SCSI controller and
> a 2GB SCSI disk.  On my LAN there's another old remoboed box,
> Daisy, with a functioning CD.
> I tried NFS-mounting it during the 5.2.1R installation ceremony.
> NG (Operation not permitted).
> Tried copying the CD onto Tomato's 4.5 system, then mounting
> /cdrom1 as /xmnt.  Again, Operation not Permitted.
> Finally, moved the good CD drive from Daisy to Tomato.  Bingo.
> Installation went fine until inodes exhausted.  But kernel was
> never installed!  It gets done after everything else!
> Problem: no info why "Operation not permitted".  Finally found
> that fsck was needed on the 40GB (although nothing was wrong).
> BIG PROBLEM:  Is there a safe way to mount a 4.5 FS onto 5.2.1?
> It seemed to work OK, but later, booting the 4.5 system, fsck
> complained bigtime.  Trashed boot block, so used the one at 32.
> For a while I'd like to be able to dual-boot 4.5 and 5.2.1, before
> committing my 40GB disk to 5.x.  Suggestions?

Dear Chuck,

I would go for the NFS mounting. Is it posible that you didn't setup the
NFS server correctly? The handbook has a good section on this topic!


Articles based on solutions that I use:

More information about the freebsd-questions mailing list