Problems with a shared library (I think)

Mikkel Christensen mikkel at
Thu Jun 3 06:28:49 PDT 2004


Since I made at buildworld that failed my computer has been quite weird.
There was a problem with which I solved by copying another version of the file from the live filesystem freebsd cd.

But after this my compiler refused to compile any C++ program.

Eventually I builded another world which was installed without any errors.
I figured this would solve my previous problems and it did to some extend.

But when I tried to upgrade KDE things went wrong. kdebase wouldn't compile and all of sudden kedinit stopped working saying it could not fint
Though the file exists in /usr/X11R6/lib/.

I decided to try and recompile the whole XFree86 server but that did not solve the problem.

At the moment kde refuses to compile showing the error "error: Qt (>= 3.2) (library qt-mt) not found".
When I try to compile /usr/ports/x11-toolkits/qt33 I get this error: "/usr/libexec/ /usr/lib/ Undefined symbol 'mbsrtowcs'"

These errors and the ones that made the system fail to begin with makes me believe there are some kind of commonly used library missing in my system.
It frustrates me that buildworld didn't solve this since I can't figure out any other sollution.

Unfortunately this machine is the one I'm using as a workstation contating all my e-mails and other stuff that I can't live without.
I'm afraid the contenc on the disk will be overwritten if I reinstall FreeBSD from scratc.

I really hope someone knows how to help since this is the computer I use every day.

Please send your reply cc to me since I'm not subscribed to the list.
Thank you.

- Mikkel

More information about the freebsd-questions mailing list