Problems connecting USB hard disk

Paul English penglish at
Thu Jul 22 10:03:51 PDT 2004

> I maybe wrong here, but i think it has something to do with you using
> USB2.0 enclosure. 4.9 doesn't support USB2.0, from 4.10 it does.
> This maybe your problem.
> Maybe someone else from the list may have a better idea than i do.

Thanks Ana. I was actually incorrect about my setup - the disk is
currently plugged into a FreeBSD 4.4 system and the other system I tried
it on was 4.10 not 4.9!

My understanding was that even when USB 2.0 is not supported, assuming
that the disk is recognized it should be recognized as USB 1.1, since both
the controller and disk are fully backwards compatible. That has been my
experience under Windows and Linux anyway. I can be almost certain that
USB 2.0 is not supported on FreeBSD 4.4, but those errors indicate that
the disk is at least recognized, but nothing useful can be done with it.

Strangely when I had it on the 4.10 system it was not even recognized!
dmesg did not even seem to notice it. I even tried using kldload to load
modules like umass, but no dice. This is why I switched it to the 4.4
system where at least it is recognized.

At the moment I don't care *where* I get it connected so long as it is to
a FreeBSD system since I need to format it to a FreeBSD filesystem rather
than FAT32. Ideally though I'd like to have it connected to a 4.10 (and in
the future presumably a 4.11 or 5.X when 5.X is production quality).


More information about the freebsd-questions mailing list