IBM 325 Server install - hangs on scsi settle

Andy Clements awc at
Fri Jan 16 13:13:31 PST 2004

fbsd_user wrote:

>Changes to PC Bios before installing FBSD
unfortunately, the BIOS on the machine is from 1997.  It's IBM's 
SureBIOS.  I've tried finding a update on IBM's site but no luck.

>Virus Warning=, set this option to disable. It's a firmware check of
>the hard drive boot sector looking for MS/Windows boot virus. This
>will stop FBSD booting from the install CDROM.
set to disable

>plug-n-play=,  set this option to disable. FBSD is not sensitive to
>Microsoft plug-n-play standard and may refuse to install, or cause
>PCI cards not to be found.
not available on BIOS

>Disable or set to auto any Bio's option to assign irq numbers to PCI
>expansion slots.
all set to auto

>Disable any ISA expansion slots.
not available on BIOS

>Operating system type=, set to 'other' or any Unix type of operating
>system, don't set to MS/Windows.
not available on BIOS

>Check to see if the cdrom drive is the slave to the IDE master Hard
>drive you are installing to, if so then move the cdrom drive to the
>secondary IDE controller as master. There should not be any cdrom
>drive sharing the primary IDE controller with the master Hard Drive.
The HDDs and CDROM are on SCSI, so I don't think they have any IDE 
controller.  Anyone can feel free to correct me on this issue if I am 

>boot sequence=, set this option to (CDROM,C) Since you are
>installing FBSD from CDROM you must tell the PC what I/O device to
>look at to boot from. Keep in mind that some older CD-ROMs drives
>and older PC bios do not support booting off CD-ROM. Generally with
>PC manufactured after 1999 this is not the problem.
BIOS is old so the old boot option I have is floppy.  The SCSI BIOS had 
a boot option, which I tried.  That failed however, and brought error 
codes from the PC BIOS because it moved the floppy drive to B: and took 
over the a: slot.

When FreeBSD attempts to boot the machine, ahc0 driver (for the Adaptec 
AIC-7880 controller) is loaded but throws the weirdest error:
ahc0: Illegal Configuration. Only two connectors on the adapter can be 
used at one time.
which means nothing to me.  Does anyone know what it is asking for?  I 
even tried removing the CDROM from the SCSI and booting , but the same 
error appears.

Others have loaded 4.9 on 325 PC Servers, however there is something 
about my configuration that is giving the ahc0 driver fits. 

again, please cc with your response as I am not on the list.

Andy Clements

original request:

>I have IBM 325 PCServer with one 200 Pentium Pro CPU and two SCSI
>drives and a SCSI CDROM.  I'm installing FreeBSD 4.9 via floppy and
>hangs when it says:
>Waiting 15 seconds for drives to settle
>I notice that it is accessing the cdrom, during the wait, but
>else happens.  I've checked the mailing list and all I see is to
>the bios virus detect off.  It seem that quite a few people are
>this problem...
>any ideas? interrupt problem?

More information about the freebsd-questions mailing list