Passing options to a 'make install clean'

Sean rsh.lists at
Fri Dec 31 16:24:58 PST 2004

Michael C. Shultz wrote:
> On Friday 31 December 2004 02:20 pm, rsh wrote:
>>I am trying to 'make install clean' of openoffice and do not want to
>>install Java.
>>I have tried several things to say no to Java but it always wants to
>>try to install jdk14, and this port is not user friendly with my
>>amd64 system.
>>So how can I install openoffice without Java?
>>                      Thanks
>>                      Sean

> According to openoffice's make file you can do something like:
> Have you tried that yet?
> -Mike
> _______________________________________________

That was about the only form I did not try, and I just did after seeing 
your message, and it seemed to work.
Now GCC is failing.
Here is last few lines with the failure. Any thoughts on why?
                 from ../../gcc-3.2.3/gcc/errors.c:25:
../../gcc-3.2.3/gcc/config/i386/x86-64.h:76:1: warning: this is the 
location of the previous definition
stage1/xgcc -Bstage1/ -B/usr/local/x86_64-portbld-freebsd5.3/bin/ 
-DIN_GCC    -g -O2 -W -Wall -Wwrite-strings -Wstrict-prototypes 
-Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long 
  genflags.o rtl.o read-rtl.o bitmap.o ggc-none.o gensupport.o 
print-rtl.o errors.o ../libiberty/libiberty.a
./genflags .././..//gcc-3.2.3/gcc/config/i386/ > tmp-flags.h
Segmentation fault (core dumped)
gmake[2]: *** [s-flags] Error 139
gmake[2]: Leaving directory `/usr/ports/lang/gcc32/work/build/gcc'
gmake[1]: *** [stage2_build] Error 2
gmake[1]: Leaving directory `/usr/ports/lang/gcc32/work/build/gcc'
gmake: *** [bootstrap] Error 2
*** Error code 2

Stop in /usr/ports/lang/gcc32.

Thanks Mike.
I just put this amd64 system together this week after my old Intel died.
The speed is impressive but I did not think there would be so many minor 
jabs getting things up again.

More information about the freebsd-questions mailing list