PXE boot / BTX Halted

Jason Taylor jason at infinitebubble.com
Thu Dec 30 00:29:08 PST 2004

Jason Taylor wrote:
> I'm trying to set up a few diskless workstations using some old 
> hardware.  I've tried four different boxes for clients ranging from a 
> P-133 to a P-200.  I did use the same Realtek 8139 based NIC in all 4 
> boxes, but I don't think that's the problem.  They all get to the point 
> where they grab pxeboot via tftp and then a message
> I'm using the instructions from 
> http://www.onlamp.com/pub/a/bsd/2004/09/09/diskless_server.html and 
> http://www.onlamp.com/pub/a/bsd/2004/09/30/diskless_clients.html
> All pointers, hints, RTFMs, etc. will be greatly appreciated.

An update with with info I hope is more useful.

I found an eepro100 card and updated the "Intel Boot Agent" to version 
4.1.16.  Using this card gets me a little further.  Taking out the 4th 
stuff per the ONLamp instructions, yields a dump and BTX Halted right after:

pxe_open: gateway ip:
/boot/kernel/kernel text=0x5021c8 data=0x7cc10+0x4fe30 

Leaving it in, it happens right after the Beastie menu timer finishes 
counting down.  In both cases I get the exact same (register?) values. 
And here they are:

int=00000006  err=00000000  efl=00010002  eip=c0650b2f
eax=00000000  ebx=c0a9a006  ecx=00000005  edx=c0a9a009
esi=c0a9a000  edi=00000005  ebp=c0c21bd0  esp=c0c21bd0
cs=0008   ds=0010  es=0010  fs=0010   qs=0010  ss=0010
es:eip=0f 44 d0 89 d0 5d c3 8d-76 00 8d bc 22 00 00 00
        00 55 89 e5 83 ec 08 8b-45 08 8b 50 04 89 54 24
ss:esp=f0 1b c2 c0 db 05 65 c0-00 a0 a9 c0 00 a0 a9 c0
        05 00 00 00 a3 5d 8e c0-00 e0 c1 00 00 00 00 00
BTX Halted

I tried a 2nd box with the same card and got the same results.

What am I doing wrong?  Are there any BIOS settings I should be 
checking?  Is my equipment simply too antiquated or not supported?  Are 
there any other debugging steps I can take?

More information about the freebsd-questions mailing list