Identical hard drives, different disklabel sectors/cylinders

Christian Hiris 4711 at
Sat Dec 18 17:32:19 PST 2004

Hash: SHA1

On Sunday 19 December 2004 00:31, wbwither at wrote:
> Hi all,
> I've got a problem question about my hard drives.  I've installed
> two brand-new Western Digital 250GB drives on the same channel of
> a Maxtor-branded PCI/IDE controller (Promise chipset).  I've tried
> different channels, different cables, and using the motherboard's
> IDE controller -- same thing every time.  Here's from
> /var/log/messages:
> Dec 18 15:59:23  /kernel: ad4: 238475MB <WDC WD2500SB-01KBA0>
> [484521/16/63] at ata2-master UDMA100 Dec 18 15:59:23  /kernel: ad5:
> 238475MB <WDC WD2500SB-01KBA0> [484521/16/63] at ata2-slave UDMA100
> So you can see it's identifying them the same at startup.  Now:
> su-2.05b# disklabel ad4
> # /dev/ad4c:
> bytes/sector: 512
> sectors/track: 63
> tracks/cylinder: 255
> sectors/cylinder: 16065
> cylinders: 30400
> sectors/unit: 488392002
> su-2.05b# disklabel ad5
> # /dev/ad5c:
> bytes/sector: 512
> sectors/track: 63
> tracks/cylinder: 16
> sectors/cylinder: 1008
> cylinders: 484520
> sectors/unit: 488397105
> So you can see, the "sectors/cylinder", "cylinders", and "sectors/unit"
> are all different, and this results in slightly different final sizes.
> I've set up vinum to create a mirror using the smaller of the two sizes,
> and it seems to be working fine, but I'm still worried about the
> implications of this.  Could this mean that one of my hard drives is
> failing?  (Again, they're both brand new.) I tried "disklabel -R"'ing each
> drive to look like the other one (booting in single-user mode), but it
> wouldn't let me.  So I'm smack out of ideas.  I'd appreciate any info or
> suggestions.

Your disks slice tables holding different values for C/H/S geometry. You can 
wipe out the slice tables with the dd(1) command and re-initialize them with 
fdisk and bsdlabel or sysinstall. There is an example written on this in 'man 
8 bsdlabel'.

It seems that your BIOS identifies geometry of both disks listed in your dmesg 
output - C/H/S 484521/16/63. This values also shown in your bsdlabel output 
of ad5. If you want to re-fdisk and re-bsdlabel ad4 it's necessary that the 
disk isn't mounted and that it isn't locked by vinum (see also 'man 4 vinum',  

IMHO there is only one thing that can go wrong with your configuration: If you 
are booting your system from the mirror, I would test if both of your drives 
are bootable.
- -- 
Christian Hiris <4711 at> | OpenPGP KeyID 0x3BCA53BE 
OpenPGP-Key at hkp:// and
Version: GnuPG v1.2.6 (FreeBSD)


More information about the freebsd-questions mailing list