Variety pack of problems installing 5.3-REL on a HP Pavilion XE746

Toomas Aas toomas.aas at
Sat Dec 18 03:15:22 PST 2004

J. Seth Henry wrote:

> It crapped out on /rescue. On the SCSI disk, /rescue is 3.5MB. When I checked 
> the ATA drive after stopping the copy, the directory was at 95MB (and the 
> filesystem hopelessly full at 109%). I tried again using copy with the same 
> results. Then, I tar'ed the folder, and extracted the tar file to the ATA 
> drive. That worked, the folder was 3.5MB just like the SCSI drive. I found I 
> could move files reliably from the SCSI drive to the ATA drive using tar, but 
> not cp. 
> I can (so far) copy files between slices on the same disk with cp without 
> error. For example, I can copy a binary from /usr to /, and the file is 
> identical.

Sorry, I can't explain the  rest of your problems, but I can explain 
this one.

The files that you see in /rescue are actually all hard links to one 
file (check it with ls -li and you see that they all have the same inode 

And from man cp we read:

Note that cp copies hard linked files as separate files.  If you
need to preserve hard links, consider using tar(1), cpio(1), or
pax(1) instead.


More information about the freebsd-questions mailing list