sound works with kldload, but not /boot/loader.conf?

Robert William Vesterman bob at
Sun Dec 12 17:16:13 PST 2004


I just tried playing a WAV file using xmms (this is the first time I've 
tried anything with sound on my installation).  It issued a very generic 
error message, telling me things like "make sure your device is 
installed".  I did some research (mostly in the FreeBSD handbook), and 
eventually got my sound working by doing a "kldload snd_driver". 

I then changed /boot/loader.conf to contain the line:


So that I wouldn't have to "kldload snd_driver" every time.  After 
rebooting, xmms acted like it was playing the song - no error message, 
equalizer lights happily jumping around, et cetera - but no sound came out.

If I try "kldload snd_driver" at this point, it says that snd_driver is 
already loaded.  If I comment out the line from /boot/loader.conf, 
reboot and do a "kldload snd_driver", the sound works fine (as it did 

So, am I doing something wrong? Is there a way to get the 
/boot/loader.conf line to work? Is there anything else I could investigate?

If it's just screwed up and that's all there is to it, could I just 
manually put "kldload snd_driver" into some automatic startup script? If 
so, what is the appropriate script?


Bob Vesterman.

More information about the freebsd-questions mailing list