Patch SSH Not Work?

Brent Bailey mrb at
Mon Sep 22 07:00:12 PDT 2003

I ran into the same thing...i ran the patch as per the directions on FBSD

but i still get the following:
sshd version OpenSSH_3.5p1 FreeBSD-20030201

when i do a ls -al on the /usr/sbin/sshd   it has the date as follows:

-r-xr-xr-x  1 root  wheel  151016 Sep 21 23:08 /usr/sbin/sshd*

that was the time i ran the i can only assume that the thing
was patched

is this the case or did i miss something ...when i did
# cd /usr/src
# patch < /path/to/sshd.patch
# cd /usr/src/secure/lib/libssh
# make depend && make all install
# cd /usr/src/secure/usr.sbin/sshd
# make depend && make all install
# cd /usr/src/secure/usr.bin/ssh
# make depend && make all install

everything seemed to go ok ... no did this work or not ?

thank you for all your help :-)
Brent Bailey CCNA
Bmyster LLC
Computer Networking and Webhosting
Network Engineer, Webmaster, President
mrb at

> At 08:27 AM 9/19/2003 -0400, Ben Dover wrote:
>>I patched my SSHD on FreeBSD ver 5.1 (base system, not ports) and after
>>stopping the SSHD server and restarting I checked the version and
>> received
>>the following:
>>schizoid# /usr/sbin/sshd -\?
>>sshd version OpenSSH_3.6.1p1 FreeBSD-20030423
>>Why did I not receive the September date?  Did the patch fail?
> Show us exactly how you patched and then restarted sshd.
> ---
> Dustin Puryear <dustin at>
> Puryear Information Technology, LLC <>
> Providing expertise in the management, integration, and
> security of Windows and UNIX systems, networks, and applications.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list