ISA Nic help

Luis Berrizbeitia luisb at
Wed Nov 5 15:25:15 PST 2003

Hi and thanks in advance to everybody who can help me with this,

Basically, I have an isa ethernet card I am trying to get recognized and configured. If someone could point me in the right direction, thanks.  Below is an explanation of some of the steps I have tried.

I have pentium II (I think) 200 mhz, 32 mb ram, with a ~3 gb hard drive.  Currently I am running version 4.8 of freebsd.  My question concerns an isa ethernet network card.  It is a Cabletron pn 9000342-04. The physical card has a section for a boot prom and as well as a set of four jumpers for the I/O address and a similar set for the boot prom.  After some research I finally found a page, apparently from the company that bought out Cabletron (Enterasys), describing the jumper configuration.  The address, for those interested is  The details of my card are available by clicking the link for the E11xx ISA 8bit card.  According to a diagram available on this website, I configured the board select jumpers to a setting of 0x280 and left the boot prom jumpers untouched, as per directions.  Also available on this site is a dos utility for the card.  I stuck the network card in the machine, booted into dos using a floppy, and pulled up the card's dos utility.  In the first screen, the user is asked which memory address is being used, listing as choices 0x220, 0x280, 0x300, 0x380.  Clicking on anything but the proper one returned a card not found error.  After clicking on 0x280, I was then taken to a page where I could set the irq, which I set to 10.  The next page offers some tests available to check the card.  One test asked which ROM address I used.  Clicking on the incorrect one will return a failed rating on some tests.  Checking the proper one, A000:0 in my case, gives the card flying colors on all tests.  I then rebooted into freebsd and tried running: device ed0 at isa? port 0x280 irq 10 from the command line and received a device: not found reply.  I checked the output of dmesg to see if I could find any irq conflicts but didn't find any (what should I be looking for?).  Using the search feature I tried finding anything with irq 10 but came up empty.  At this point, after checking FreeBSD Unleashed, the author basically says if you have an isa card, have fun configuring it.  He really does not go into details apart from suggesting reading the driver's man page.  From what I gather, this particular card is NE2000 compatible or so I think.  Since I could not read the ed driver's man page (what is it called?) I decided on reinstalling and using the kernel configuration section instead of skipping it like I had done previously.  I selected network, ne2000 compatible card, and entered the proper memory addresses and irq numbers. This did not seem to make the card work.  One thing I forgot to mention is that both the green light on the card and on a switch when I plug in a patch cable light up.  Don't know if that helps.  I am not running X so if anyone has any ideas please suggest stuff to do from the shell (although gui tips will be appreciated if all else fails).  Lastly, I know many of you will point out that the card does not seem to be listed in the Hardware support list.  I know but again it appears to be ne2000 compatible (if I am wrong please correct me and tell me not to be so skimpy and just buy a pci card and forget about it).  Again, thanks to anybody who can help.

Best regards,

More information about the freebsd-questions mailing list