pam-pgsql + saslauthd[cyrus-sasl2]

Andrew A. Khlebutin andrey at hm.perm.ru
Fri May 30 06:01:30 PDT 2003


Hi,

Does anyone use pam-pgsql + saslauthd? I did everything according to
the given instructions in pam-pqsql readme file but it doesn't work
anyway. This is what is writes in auth.log file:
======
May 29 14:10:15 <auth.err> hm saslauthd[69967]: in openpam_load_module(): no /usr/lib/pam_pgsql.so found
May 29 14:10:15 <auth.info> hm saslauthd[69967]: do_auth : auth failure: [user=andrew] [service=pop] [realm=] [mech=pam]
======

$ls -l /usr/lib/pam_pgsql.so
-r--r--r--  1 root  wheel  14052 26 май 12:30 /usr/lib/pam_pgsql.so

I switched on the debug option in PostgreSQL but it says that noone
tried to connect ... :(.

I've read all those short manuals but I can't understand what's wrong.
Has anyone solved the similar problem or do you have any ideas of how
to localize this problem solution?

P.S: FreeBSD 5.0-p7, pam-pgsql-0.5.2_7, cyrus-sasl-2.1.13_2.

========================cat /etc/pam_pgsql.conf======================
host = 127.0.0.1
database = mail
user = cyrus
password = mycoolpasword
table = accounts
user_column = name
pwd_column = password
expired_column = acc_expired
newtok_column = acc_new_pwreq
pw_type = clear
debug
========================cat /etc/pam_pgsql.conf======================

========================cat /etc/pam.d/pop==========================
auth        required    /usr/lib/pam_pgsql.so   debug
account     required    /usr/lib/pam_pgsql.so   debug
password    required    /usr/lib/pam_pgsql.so   debug
========================cat /etc/pam.d/pop3==========================

-- 
Best regards,
Andrew A. Khlebutin



More information about the freebsd-questions mailing list