need help repairing this system... mount issues

Bsd Neophyte bsdneophyte at
Sun May 18 18:53:50 PDT 2003

--- Joshua Oreman <oremanj at> wrote:
> Before you do that, why not try this?
> Booting [kernel] in 9 seconds... [space]
> ok boot -s
> [snip]
> mountroot> ufs:/dev/ad4s1a
> [snip]
> # mount -uw /
> # cd /dev && sh MAKEDEV ad4
> # mount -a
> The key command is 'mount -uw /'. This tells the system to remount /
> read-write. It does not need the device file used to mount the
> partition.

alright tried this, but "mount -uw" gives the following error:

WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck
mount: /dev/ad0s1a: Operation not mermitted

so i tried running fsck which gives the following error:

Can't open /dev/ad0s1a: Device not configured
Can't open /dev/ad0s1e: Device not configured

so i thought i'd run fsck on the device nodes located in /mnt (made using
the method suggested in a previous message), but then i realized that I
don't know exactly how that will help either.

here's one thing that confuses me.  when i boot and it asks me for the
location of the boot slice, i enter /dev/ad4s1a, but the thing is that
this doesn't exist in /dev.  so how exactly is the system booting through
what it should consider a phantom slice?

again... and any all help is greatly appreciated. :)

Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.

More information about the freebsd-questions mailing list