Changed a filesystem's name -- now system hangs on reboot (help)

greg at greg at
Wed Jul 9 20:09:48 PDT 2003

Any help appreciated... I feel like I've painted myself into a corner.

The problem: system drops into /bin/sh on reboot without going through a
full reboot because it can't find a filesystem (/storage) that it's looking
for. I can't get into /etc/fstab to comment out the offending line because
I can't get booted.

This is as far as the boot gets:

# mount: /storage: No such file or directory
# Mounting /etc/fstab filesystems failed, startup aborted
# Enter full pathname of shell or RETURN for /bin/sh:

Background: I turned /storage into /var/ftp/many_more_files by unmounting
it and renaming it and remounting it. Everything worked fine until I needed
to do a reboot following a physical move of the box.

I've looked through the handbook and tried (unsuccessfully) to reboot into
single-user mode or otherwise get to a place where I can either comment out
the line in fstab or skip the check -- no luck.

Any ideas much appreciated.


mail2web - Check your email from the web at .

More information about the freebsd-questions mailing list