Swapped disks and now stuck in the mountroot> prompt

Alexander Farber Alexander.Farber at t-online.de
Thu Dec 25 16:46:11 PST 2003


I've installed FreeBSD 4.9 via FTP on my T22-laptop
while having the hard disk as my first disk on it
and then I had to put that disk into the ultrabay
and thus have made it the second disk.

I know, that all I have to do is probably to edit
the /etc/fstab but I can't get there - I'm stuck
at the mountroot> prompt. I've tried all the possible
combinations including the one which I'd expected
to be correct: "ufs:/dev/ad2s1a" but they all fail
with "Root mount failed: 22".

The "?" at the mountroot> prompt does show "ad" device.

And the lines in the grub/conf on the 1st hard drive
which I use to load that 2nd hard drive look like:

	title FreeBSD
	root (hd1,0,a)
	kernel /boot/loader

	title OpenBSD
	root (hd1,1,a)
	chainloader +1

(The OpenBSD has worked already - I had booted /bsd.rd, 
mounted the / and edited the /etc/fstab).

I couldn't find the answer in the Handbook or on Google
yet... Any help? Thank you


More information about the freebsd-questions mailing list