cdrom - device not configured error

Malcolm Kay Malcolm.Kay at
Fri Apr 18 19:11:54 PDT 2003

On Sat, 19 Apr 2003 08:04, Michelle Weeks wrote:
> On Friday, April 18, 2003, at 03:20 PM, W. Sierke wrote:
> > "Michelle Weeks" wrote:
> >> i'm trying to mount /dev/acd0c and i keep getting the error "device
> >> not
> >> configured".  the freebsd handbook states that either the drive does
> >> not think there is a cd in the tray or the machine can't see the drive
> >> on the bus.  i've put the cd in the tray several times, tried multiple
> >> cds that can be read by another freebsd machine and still the error
> >> "device not configured".  this is a production server and i would like
> >> to avoid bringing the server down if at all possible.  is there a way
> >> to tell if the machine can see the cdrom drive on the bus?  or is
> >> there
> >> something else that could be causing this behavior?
> >
> > atacontrol should be useful. Note the warnings in the manpage about
> > potential (bad!) results of incorrect usage, however! But should be
> > fine to
> > use the 'list' command for this purpose:
> >
> > # atacontrol list
> > ATA channel 0:
> >     Master:  ad0 <ST380024A/3.33> ATA/ATAPI rev 6
> >     Slave:       no device present
> > ATA channel 1:
> >     Master: acd0 <CD-ROM 40X/AKU/T02> ATA/ATAPI rev 0
> >     Slave:       no device present
> >
> > That should at least tell you if it's seeing the drive. You could
> > perhaps
> > try the "reinit" command on the appropriate channel (if it only has the
> > cdrom, etc. on it), but perhaps only as a last resort in case it has
> > unwanted consequences! It's quite possible that the drive is simply no
> > longer serviceable. :(
> thank you wayne.  i tried the command atacontrol list and get the
> following error: atacontrol: control device not found: No such file or
> directory?

I am certainly no expert in this matter; but it sounds to me as though
you might be missing /dev/ata which I think is used by atacontrol.

If it is missing then from /dev running './MAKEDEV ata' might get atacontrol 

As an aside I have had problems with at least one FreeBSD release
and cdrom on a master IDE port but no problem on a slave port.

Malcolm Kay 

More information about the freebsd-questions mailing list