Expertise needed: problem.

Thierry Thomas thierry at
Sun Nov 18 06:20:09 PST 2007


I have been trying to port Miro (formerly Democracy) for some time. This
application is very interesting: e.g. it lets you watch videos from
Youtube or Dailymotion without a flash plug-in.

My port is available from

I builds and installs fine, and runs OK on some machines but fails
(Python core dumps) on some others.

I have tried to find differences between a working machine and a failing
one, without success!

However, I've noticed that build scripts are different, even if both of
them produce the same files:

- when the resulting installation is OK, the build begins with
Compiling 'playlisttab' template to /usr/ports/multimedia/miro/work/Miro-1.0/resources/../portable/compiled_templates/

- when it is not, the build begins with
Compiling 'new' template to /usr/ports/multimedia/miro/work/Miro-1.0/resources/../portable/compiled_templates/

but I don't understand what causes this difference!

- there is no impact from py25-setuptools;
- tried with -vv, but that did not give me any clue;
- building in a tinderbox produces a failing application, then I guess
  that some dependency or some environment variable is missing;
- if you want to give it a try: it is quick to build, but requires many
  dependences (add them as packages if needed).

Th. Thomas.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-python mailing list