ppc64 snapshot

Justin Hibbits jrh29 at alumni.cwru.edu
Sat Apr 10 02:50:57 UTC 2010


On Fri, Apr 9, 2010 at 9:20 PM, Nathan Whitehorn <nwhitehorn at freebsd.org>wrote:

>  On 04/09/10 19:54, Justin Hibbits wrote:
>
> On Thu, Apr 8, 2010 at 9:57 PM, Justin Hibbits <jrh29 at alumni.cwru.edu>wrote:
>
>>  On Tue, Apr 6, 2010 at 1:22 PM, Nathan Whitehorn <nwhitehorn at freebsd.org
>> > wrote:
>>
>>> Justin Hibbits wrote:
>>>
>>>>  I just got my hands on a dual-core G5 (Late 2005), and want to throw
>>>> -CURRENT on it.  Is there a snapshot available with the recent ppc64
>>>> changes
>>>> that I could test out?
>>>>
>>>> - Justin
>>>>  _______________________________________________
>>>> freebsd-ppc at freebsd.org mailing list
>>>> http://lists.freebsd.org/mailman/listinfo/freebsd-ppc
>>>> To unsubscribe, send any mail to "freebsd-ppc-unsubscribe at freebsd.org"
>>>>
>>>>
>>> I just finished implementing the last missing feature in the 64-bit
>>> PowerPC port, and there are no more 64-bit-specific bugs that I know about.
>>> Once M. Warner Losh's build system changes are in the tree, I will submit a
>>> final patch set for review, and merge it to head, but the port should be
>>> completely usable at this point.
>>>
>>> System Compatibility:
>>> - Apple G5 machines
>>>
>>> Caveats:
>>> - Do not run ofwdump on an SMP system, as it can cause hangs (also a
>>> 32-bit bug)
>>> - Many ports (e.g. X and GTK) need patches not currently in the ports
>>> tree to compile, since this is a new platform
>>>
>>> Instructions:
>>> svn co http://svn.freebsd.org/base/projects/ppc64
>>> cd ppc64
>>> make buildworld buildkernel installkernel installworld distribution
>>> DESTDIR=/path/to/installation TARGET_ARCH=powerpc64
>>>
>>> I would appreciate any feedback or tests, as well as testing on 32-bit
>>> Book-E systems to make sure I did not break anything. Many thanks to Andreas
>>> Tobler for his tireless testing efforts during development of this port.
>>>  -Nathan
>>>
>>>
>>  I've finally had a chance to test it, but it hangs with the string
>>
>>  Kernel entry at 0x1034e0...
>>
>>  nothing more.  I tried booting verbose, but that gave nothing, it looks
>> like it may not even be leaving the loader.
>>
>>  - Justin
>>
>
> I just tried a fresh head boot, and I got the same thing loading a ppc32
> kernel.  Trying with hw.physmem=512M (the machine has 4GB physical memory)
> failed as well, and loading a ppc32 kernel from loader.ppc64 same result.
>  Any ideas of how to continue debugging this?
>
>  - Justin
>
> This sounds like an issue with syscons. Can you try setting
> hw.syscons.disable=1 from the loader? That should make the kernel fall back
> to the Open Firmware text console.
> -Nathan
>

Same result, with both ppc32 and ppc64 kernels.  Should I just start
riddling the kernel with printf()s to track this down?

- Justin


More information about the freebsd-ppc mailing list