Problems with the loader

Philip S. Schulz ph.schulz at
Sat Aug 5 20:03:04 UTC 2006


  I'm having trouble installing the latest snapshot on my 12" PowerBook 
G4. I bought it in February 2006, so I think it's the last revision 
before they stopped selling the PowerBooks. I managed to start the 
loader but then the loader complains "can't load kernel". Here's what 
I've tried so far:

  1. Hold down 'C' while booting: I can hear the CD spin up, it seems
like there is disk activity but then the drive spins down again and Mac 
OS X is started.

  2. At the Open Firmware prompt, type "boot cd:,\boot\loader": The
loader starts, but says: "can't load 'kernel'" and then "no bootable kernel"

  3. I have tried to explicitely tell the loader where to load the 
kernel from by issuing "set currdev=cd:," and then try to type "boot" 
again. Unfortunately that didn't work, either. Makes sense, since the 
loader prints the correct boot device when started. Tried "boot 
/boot/kernel" and then the loader complains "Cant't find /boot/kernel".

  4. Also I have tried to copy boot/ from the CD to the internal 
harddisk an boot from there by saying "boot hd:,\boot\loader" at the 
Open Firmware prompt. Same effect as in 2.

  5. Finally I have tried an older kernel, the one that is on the 
2005/12/06 snapshot. Same problems.

I'm sure it's something that I'm doing wrong, but I haven't been able to
find out just what. Does anybody know what it might be?



Don't fix it if it ain't broke.

More information about the freebsd-ppc mailing list