nodejs v0.4

Norman Khine norman at
Fri Sep 23 09:17:15 UTC 2011

hello, i have tried to build nodejs from the ports, but get this error:

# cd /usr/ports/www/node
# make install clean && rehash
===>  Building for node-0.4.11
Waf: Entering directory `/usr/ports/www/node/work/node-v0.4.11/build'
DEST_OS: freebsd
Parallel Jobs: 1
Product type: program
[53/74] cxx: src/ -> build/default/src/node_buffer_3.o
c++ -O2 -pipe -fno-strict-aliasing -pthread -g -O3 -DHAVE_OPENSSL=1 -
D__POSIX__=1 -Wno-unused-parameter -D_FORTIFY_SOURCE=2 -Idefault/src -
I../src -Idefault/deps/libeio -I../deps/libeio -Idefault/deps/
http_parser -I../deps/http_parser -Idefault/deps/libev -I../deps/libev
-Idefault/deps/c-ares -I../deps/c-ares -Idefault/deps/c-ares/freebsd-
x64 -I../deps/c-ares/freebsd-x64 -I/usr/include -I/usr/local/
include ../src/ -c -o default/src/node_buffer_3.o
../src/ In static member function 'static
v8::Handle<v8::Value> node::Buffer::Utf8Write(const v8::Arguments&)':
../src/ error: 'NO_HINTS' is not a member of
Waf: Leaving directory `/usr/ports/www/node/work/node-v0.4.11/build'
Build failed:  -> task failed (err #1):
        {task: cxx -> node_buffer_3.o}
*** Error code 1

Stop in /usr/ports/www/node.

from the node groups,
it was pointed that the port was trying to build against a shared
libv8 and it's too old.

i tried to follow different suggestions, but no answer as yet, anyone
here able to point me in a direction that will allow me to build
latest stable nodejs.


%>>> "".join( [ {'*':'@','^':'.'}.get(c,None) or
chr(97+(ord(c)-83)%26) for c in ",adym,*)&uzq^zqf" ] )

More information about the freebsd-ports mailing list