[SOLVED] Re: Building caire and $PATH order

Xavier HUMBERT xavier.humbert at xavhome.fr.eu.org
Wed Oct 19 12:09:23 UTC 2011

Xavier HUMBERT <xavier.humbert at xavhome.fr.eu.org> wrote:

> A couple of weeks ago, after installing openssl from ports, I changed
> PATH order in my .bash_login, in order to use /usr/local before /usr an
> so on.
> Today, I upgraded icu, and its dependants, including cairo. The build
> was successful until reaching cairo :

Well, after digging in configure script, and putting some debug code,
the culprit is ....
It has a "strings" binary" which exhibits the very same error :
> [root at valinor ~]# /usr/local/sbin/strings --help
> fopen: No such file or directory

And, in fact, the problem has already been reported in freebsd-gnome :

I dunno why chkrootkit uses a very common and standard binary name for
their own.

In your pomp and all your glory you're a poorer man than me,
as you lick the boots of death born out of fear.
(Jethro Tull)

More information about the freebsd-ports mailing list