Call for testers -- CONF_FILES variable
crees at freebsd.org
Fri Jul 1 07:30:27 UTC 2011
On 30 Jun 2011 12:18, "Julien Laffaye" <jlaffaye at freebsd.org> wrote:
> On 06/30/2011 08:22, Chris Rees wrote:
> >> I like the rest, but I do not like the name of .pkgconf. I think, the
> >> 'pkgconf' is best define for something related with FreeBSD rather
> >> than third-party product. The .sample or .default is best name and
> >> less confuse for the users, because the word said it all what it is.
> > Thanks for the feedback.
> > I'm afraid any problems with the .pkgconf sample will have to be
> > discussed with the pkgng team and bapt@ -- wasn't my choice either.
> > Chris
> Yes, right now, pkgng uses the .pkgconf suffix to know that it is a
> configuration file. But now, we have a new format for the package
> manifest so _maybe_ (it has to be discussed with bapt) we can add an
> attribute to a file entry saying "I am a sample of a conf file". The
> hardest part for that would be to detect in the ports tree if we are
> using pkgng or the legacy pkg_install, and, depending on that, to
> generate the appropriate entry in the manifest / plist.
So perhaps that suffix should stay. I certainly don't relish the prospect
otherwise of having to cull every unexec cmp in the entire ports tree....
More information about the freebsd-ports