Problem installing ntop on 7.3 FreeBSD

Mike Sabroff msabroff at
Mon Jan 3 18:26:00 UTC 2011

I saw something on this tool (ntop) and decided to check it out.
I did the make and then tried ti install. I got the following error :

make install
===>  Installing for ntop-3.3.10_3
===>   ntop-3.3.10_3 depends on executable: dot - not found
===>    Verifying install for dot in /usr/ports/graphics/graphviz
===>  graphviz-2.26.3 option WITH_GTK is required for option WITH_GNOMEUI.
*** Error code 1

Stop in /usr/ports/graphics/graphviz.
*** Error code 1

Stop in /usr/ports/net/ntop.
*** Error code 1

Stop in /usr/ports/net/ntop.

I understand that when I chose the "WITH_GNOMEUI" option that I should 
hve also chosen the "WITH_GTK" option as well, though I didn't know that 
at the time.

I have tried to make clean, and also make clean in the GeoIP and libpcap 
dirs to start over but I don't get the option screens now and don't know 
how to reset the options so the install will work.

How can I either reset these options or reset the whole build so I get 
the option screens again?


More information about the freebsd-ports mailing list