Looks as if we need a misc/compat8x

David Wolfskill david at catwhisker.org
Tue Aug 10 12:20:38 UTC 2010


I rebuilt the installed ports on my build machine under stable/8
yesterday (as there are no other machinies for which it builds that run
stable/7 any more).

No surprises when I updated local mirrors overnight or built today's
stable/8.

But then I rebooted under head (different slice), and found that
screen(1) needed libutil.so.8, and sudo(1) need both that and libz.so.5.

I copied the requisite libraries to /usr/local/lib/compat/pkg from the
stable/8 slice, and so far, things appear back to normal.

I expect that a "real" compat8x port might need a few more libraries --
my build machine has a rather small number of installed ports....

Peace,
david
-- 
David H. Wolfskill				david at catwhisker.org
Depriving a girl or boy of an opportunity for education is evil.

See http://www.catwhisker.org/~david/publickey.gpg for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20100810/cd6cca1e/attachment.pgp


More information about the freebsd-ports mailing list