Unable to build /lang/ruby18

Dominic Fandrey kamikaze at bsdforen.de
Wed Apr 28 08:57:44 UTC 2010

On 04/04/2010 23:37, Sahil Tandon wrote:
> On Sun, 04 Apr 2010, Jerry wrote:
>> I have tried three times in the past 24 hours to build the
>> 'lang/ruby18' port without success. This is on a FreeBSD-7.3 machine.
>> The build log follows:
>> Script started on Sun Apr  4 03:59:59 2010
>> ===>  Found saved configuration for ruby+nopthreads-,1
> OK, +nopthreads; but during build:
>> -rpath=/usr/local/lib -pthread  -o miniruby rbconfig.rb updated cc
>                         ^^^^^^^^
> Odd.  FWIW, my lang/ruby18 build log WITHOUT_PTHREADS=yes on 7.3:
>  http://pastie.org/903044.txt

I had this issue, too. It worked after running 'make rmconfig',
because WITHOUT_PTHREADS was stored in the options file and
breaking the ports logic.

A: Because it fouls the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail? 

More information about the freebsd-ports mailing list