Source-upgrading FreeBSD "breaks" postfix+dovecot?

Darren Pilgrim freebsd at
Wed Jan 7 01:51:03 UTC 2009

Xin LI wrote:
> Darren Pilgrim wrote:
>> Tonight I source-upgraded a FreeBSD system from i386 6.3p5 to i386
>> 6.4-R.  I have postfix 2.5.5 and dovecot 1.1.7 installed with postfix
>> using dovecot for SASL and dovecot LDA for mailbox delivery.  After
>> installing 6.4-R, postfix refused to work until I recompiled and
>> reinstalled both it and dovecot.  Dovecot itself (i.e., the IMAP server)
>> worked fine.  Postfix worked fine if I set smtpd_sasl_auth_enable=no and
>> defer_transports=dovecot, effectively preventing postfix from using any
>> dovecot bits.  Examples of the logged errors:
>> Before reinstalling anything:
>> postfix/pipe[36617]: fatal: get_service_attr: unknown group: vmail
> Sounds like that you have did something really bad during mergemaster?
> (i.e. installed /etc/group without actually doing merge) and in turn the
> group gets removed...

The only change to /etc/group was the CVS ID tag.  Group resolution 
worked for other programs--ls showed "vmail" rather than the numeric 
gid, chown worked with :vmail, etc.

I verified libraries matched with another 6.4-R system.  I power cycled 
the system thinking there may have been stale libraries or some 
mysterious form of cache corruption in memory; however, the problem 

The problem didn't go away until I rebuilt the ports.

More information about the freebsd-ports mailing list