net/samba3 not installing VFS modules

Erik Van Benschoten evanben at
Fri Sep 26 16:37:21 UTC 2008

On Sep 26, 2008, at 10:27 AM, Scot Hetzel wrote:

> On 9/25/08, Erik Van Benschoten <evanben at> wrote:
>> Greetings,
>>  I have been looking into setting up a network recycle bin under  
>> v3.0.32 of
>> Samba. The default configuration does not install/package any of  
>> the VFS
>> modules from the looks of it. The man pages are there for them, but  
>> not the
>> actual binaries. After looking at the Makefile I tried to add the  
>> following
>> to /etc/make.conf:
>> WANT_EXP_MODULES+=      vfs_recycle
>> That failed to install the recycle VFS module, so I tried:
>> WANT_EXP_MODULES=       vfs_recycle
>> Still no luck. The VFS modules are getting compiled, but are  
>> apparently not
>> getting added to the packing list. Anyone have any suggestions? Is  
>> anyone
>> else having this problem?
> You don't need to add the WANT_EXP_MODULES /etc/make.conf, as the
> vfs_recycle module is a standard module in Samba.
> After a make configure, I looked at the resulting Makefile, and it
> does show that vfs_recycle is listed as a VFS_MODULES.  Then when a
> make install was performed, the module was located in the
> PREFIX/lib/samba/vfs directory.
> Did you check this directory?
> Scot


  The problem was not getting the VFS modules compiled, but rather  
getting them installed.

I found a brute force workaround was to manually add 'lib/samba/vfs/' to the '/net/samba3/pkg-plist' file.
I know this is not the proper thing to do, but it works for getting a  
package built.  I would have preferred a tweak to the Makefile that  
would work for everyone, but I'm afraid my Makefile reading skills are  
not up to snuff.


More information about the freebsd-ports mailing list