Ruby port broken? SOLVED

Jack Raats jack at
Sat Aug 16 07:28:35 UTC 2008


This error is the same I got this morning. After the new commit this problem 
was solved.
Please update the ports tree and try again.


----- Original Message ----- 
From: "Chad Perrin" <perrin at>
To: <freebsd-ports at>
Sent: Saturday, August 16, 2008 9:17 AM
Subject: Re: Ruby port broken? SOLVED

On Sat, Aug 16, 2008 at 08:35:00AM +0200, Jack Raats wrote:
> The new commit solved the problem.

Apparently, whatever worked for you hasn't done me any good:

  ===>  Patching for ruby-,1
  ===>  Applying FreeBSD patches for ruby-,1
  Ignoring previously applied (or reversed) patch.
  3 out of 3 hunks ignored--saving rejects to lib/cgi.rb.rej
  => Patch patch-lib_cgi.rb failed to apply cleanly.
  => Patch(es) patch-ext_tk_tkutil_extconf.rb patch-io.c applied cleanly.
  *** Error code 1

  Stop in /usr/ports/lang/ruby18.
  *** Error code 1

  Stop in /usr/ports/lang/ruby18.
  ** Command failed [exit code 1]: /usr/bin/script -qa
  /tmp/portupgrade.20719.0 env UPGRADE_TOOL=portupgrade
  ** Fix the problem and try again.

Chad Perrin [ content licensed PDL: ]
Jon Postel, RFC 761: "[B]e conservative in what you do, be liberal in
what you accept from others."

More information about the freebsd-ports mailing list