Conflicts during install the mplayer

RW fbsd06 at mlists.homeunix.com
Fri Sep 21 08:20:21 PDT 2007


On Fri, 21 Sep 2007 15:58:45 +0400
Boris Samorodov <bsam at ipt.ru> wrote:

> On Fri, 21 Sep 2007 18:33:45 +0800 veeeye wrote:
> 
> > hi,
> > i  tried to install the mplayer to my freebsd6.2 with ports,
> > and  got this question:
> 
> > ===>  linux-gdk-pixbuf-0.22.0.18.fc4.2 conflicts with installed
> > package(s): linux-gtk2-2.6.10
> 
> >       They install files into the same place.
> >       Please remove them first with pkg_delete(1).
> > *** Error code 1
> 
> > Stop in /usr/ports/graphics/linux-gdk-pixbuf.
> > *** Error code 1
> 
> > I removed the package linux-gtk2-2.610,
> > and then installed it  suncessful.
> 
> > during the process ,i saw that the mplayer depends on the
> > linux_base_fc4, and the linux-gtk2-2.610 was installed for this
> > reason, and the conflict happened later.
> 
> > Is this a problem of my installed or a bug of ports?
> 
> Can't reproduce it here:
> ...
> srv% make all-depends-list | grep linux
You wont see any such dependencies if you don't have the realplayer
option set.

I'm not sure what the answer is. IIRC correctly I had to do it the
other way around and delete linux-gdk-pixbuf.

If you haven't already done so, I'd suggest bringing the other ports
up-to-date.


More information about the freebsd-ports mailing list