openoffice 2 (RC, devel) broken

Maho NAKATA chat95 at
Sun Mar 4 23:53:09 UTC 2007

From: Oliver Lehmann <lehmann at>
Subject: Re: openoffice 2 (RC, devel) broken
Date: Fri, 02 Mar 2007 14:14:14 +0100

> tried it again with the latest STABLe, gcc41 and openoffice port...
> still the same:
> g++41 -O     -shared -Wl,-soname -Wl, -o ../lib/ locbund.o ufile.o ufmt_cmn.o uprintf.o uprntf_p.o uscanf.o uscanf_p.o ustdio.o sprintf.o sscanf.o ustream.o ucln_io.o -L../lib -licuuc -L../lib -L../stubdata -licudata -L../lib -licui18n -lpthread -lm 
> /usr/bin/ld: /usr/local/lib/gcc-4.1.2/gcc/x86_64-portbld-freebsd6.2/4.1.2/../../../libstdc++.a(ios_init.o): relocation R_X86_64_32 can not be used when making a shared object; recompile with -fPIC
> /usr/local/lib/gcc-4.1.2/gcc/x86_64-portbld-freebsd6.2/4.1.2/../../../libstdc++.a: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> gmake[1]: *** [../lib/] Error 1
> rm
> gmake[1]: Leaving directory `/usr/obj/usr/ports/editors/'
> gmake: *** [all-recursive] Error 2
> dmake:  Error code 2, while making ''
> ---* *---
> ERROR: Error 65280 occurred while making /usr/obj/usr/ports/editors/
> dmake:  Error code 1, while making 'build_instsetoo_native'
> ---*  *---

Dear Oliver,
thanks for your repot.
Could you please ask at openoffice ML again?
Unfortunately I own an opteron box but have never encountered such a problem...

-- NAKATA, Maho (maho at

More information about the freebsd-ports mailing list