FreeBSD Port: mod_python-2.7.11 - Script "configure" failed unexpectedly.

Philip Semanchuk philip at semanchuk.com
Wed Feb 1 09:48:32 PST 2006


Hi Josh,
I was trying to build mod_python on my box but got 'Script "configure" 
failed unexpectedly.' I'm running on FreeBSD 6.0, generic kernel, 
Apache 2.1.4. I'm a clueless n00b to *nixland so there's nothing too 
fancy about my setup, although I can't rule out having done something 
"obviously" stupid. Ordinarily with an error like this I'd assume that 
I'm at fault (which might still be the case) but I gather than the 
ports collection is supposed to be pretty idiot-proof and shouldn't 
break this easily, so I'm contacting you as per the message from 
configure. I Googled for 'mod_python Script configure failed 
unexpectedly' and got only a handful of irrelevant hits. Included below 
is the debug info that the script suggested I send to you. Let me know 
if I can help with troubleshooting. Any suggestions/info you can 
provide would be appreciated.

Cheers
Philip

output from make:
------------------------------------ begin 
------------------------------------
root at whiskey# cd /usr/ports/www/mod_python
root at whiskey# make
===>   mod_python-2.7.11 depends on file: /usr/local/sbin/apxs - found
===>   mod_python-2.7.11 depends on file: /usr/local/bin/python - found
===>  Configuring for mod_python-2.7.11
loading cache ./config.cache
checking for gcc... (cached) cc
checking whether the C compiler (cc -O2 -fno-strict-aliasing -pipe  ) 
works... yes
checking whether the C compiler (cc -O2 -fno-strict-aliasing -pipe  ) 
is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether cc accepts -g... (cached) yes
checking for ranlib... (cached) ranlib
checking for ar... (cached) ar
checking for a BSD compatible install... /usr/bin/install -c -o root -g 
wheel
checking whether make sets ${MAKE}... (cached) yes
checking for main in -lm... (cached) yes
checking for working const... (cached) yes
checking your blood pressure... a bit high, but we can proceed
checking whether apxs is available
checking for --with-apxs... /usr/local/sbin/apxs executable, good
checking for Apache libexec directory... /usr/local/libexec/apache21
checking for Apache include directory... -I/usr/local/include/apache21
checking for --with-apache... no
configure: warning: **** No apache sources specified, static 
compilation will not be available.
configure: warning: **** You can use --with-apache to specify where 
your Apache sources are.
checking for --with-python... no
checking for python... (cached) /usr/local/bin/python
checking Python version... 2.4
checking whether Python is compiled with thread support... no threads, 
good
checking Python install prefix... /usr/local
checking what libraries Python was linked with... 
/usr/local/lib/python2.4/config/libpython2.4.a    -lutil   -lm
checking linker flags used to link Python...
checking where Python include files are... 
-I/usr/local/include/python2.4
checking for mkdep... (cached) /usr/bin/mkdep
updating cache ./config.cache
creating ./config.status
creating Makefile
creating src/Makefile
creating src/libpython.module
creating Doc/Makefile
analyzing dependencies
===>  Script "configure" failed unexpectedly.
Please report the problem to josh at elsasser.org [maintainer] and attach 
the
"/usr/ports/www/mod_python/work/mod_python-2.7.11/config.log" including 
the
output of the failure of your make command. Also, it might be a good 
idea to
provide an overview of all packages installed on your system (e.g. an 
`ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/www/mod_python.
root at whiskey#
------------------------------------ end 
------------------------------------


Here's the config.log:
------------------------------------ start 
-----------------------------------
root at whiskey# cat 
/usr/ports/www/mod_python/work/mod_python-2.7.11/config.log
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:538: checking for gcc
configure:651: checking whether the C compiler (cc -O2 
-fno-strict-aliasing -pipe  ) works
configure:667: cc -o conftest -O2 -fno-strict-aliasing -pipe    
conftest.c  1>&5
configure:693: checking whether the C compiler (cc -O2 
-fno-strict-aliasing -pipe  ) is a cross-compiler
configure:698: checking whether we are using GNU C
configure:726: checking whether cc accepts -g
configure:760: checking for ranlib
configure:793: checking for ar
configure:854: checking for a BSD compatible install
configure:907: checking whether make sets ${MAKE}
configure:935: checking for main in -lm
configure:980: checking for working const
configure:1057: checking your blood pressure
configure:1062: checking whether apxs is available
configure:1069: checking for --with-apxs
configure:1159: checking for Apache libexec directory
configure:1165: checking for Apache include directory
configure:1185: checking for --with-apache
configure:1222: checking for --with-python
configure:1241: checking for python
configure:1321: checking Python version
configure:1327: checking whether Python is compiled with thread support
configure:1346: checking Python install prefix
configure:1356: checking what libraries Python was linked with
configure:1387: checking linker flags used to link Python
configure:1402: checking where Python include files are
configure:1418: checking for mkdep
root at whiskey#
------------------------------------ end 
------------------------------------

Here's my list o' packages:
------------------------------------ start 
----------------------------------
root at whiskey# ls /var/db/pkg/
ORBit2-2.12.2                   libexif-0.6.12_1
OpenEXR-1.2.1_1                 libgcrypt-1.2.1_1
apache-2.1.4                    libglade2-2.5.1_2
arts-1.4.2,1                    libgnome-2.10.1
artswrapper-1.2.2               libgnomecanvas-2.10.2_1
aspell-0.60.3                   libgnomeprint-2.10.3_1
atk-1.9.1                       libgnomeprintui-2.10.2
autoconf-2.59_2                 libgnomeui-2.10.1_1
bash-3.0.16_1                   libgpg-error-1.0_1
bison-1.75_2                    libgsf-1.11.1_1
bitstream-vera-1.10_1           libiconv-1.9.2_1
cdparanoia-3.9.8_7              libidn-0.5.18
cups-base-1.1.23.0_5            libltdl-1.5.18
cyrus-sasl-2.1.21               libmad-0.15.1b_1
db41-4.1.25_3                   libmng-1.0.8
desktop-file-utils-0.10_2       libogg-1.1.2_1,3
docbook-sk-4.1.2_3              libpaper-1.1.14.3
docbook-xml-4.2_1               librsvg2-2.9.5_2
docbook-xsl-1.68.1              libsndfile-1.0.11
eel-2.10.1_1                    libsoup-2.2.3
esound-0.2.36                   libtasn1-0.2.13
evolution-data-server-1.2.3     libtool-1.5.18
expat-1.95.8_3                  libusb-0.1.10a
fam-2.6.9_6                     libvorbis-1.1.1,3
fileroller-2.10.4,1             libwnck-2.10.3
fontconfig-2.2.3,1              libwpd-0.8.0_1
freetype2-2.1.10_1              libxml2-2.6.20
gail-1.8.4                      libxslt-1.1.14
gconf2-2.10.1                   linc-1.0.3_3
gettext-0.14.5                  linux_base-8-8.0_6
glib-2.6.6                      lynx-2.8.5
gmake-3.80_2                    m4-1.4.3
gnome-icon-theme-2.10.1_1       mDNSResponder-107.1_1
gnome-menus-2.10.2_1            mod_php5-5.0.4_2,1
gnomedesktop-2.10.2             mysql-client-4.1.13
gnomegames2-2.10.2              nas-1.7
gnomehier-2.0_7                 nautilus2-2.10.1
gnomekeyring-0.4.3_1            netatalk-2.0.3,1
gnomemimedata-2.4.2             nspr-4.6
gnomepanel-2.10.2               nss-3.10
gnomeutils2-2.10.1,1            openldap-client-2.2.27
gnomevfs2-2.10.1                p5-XML-Parser-2.34_1
gnu-autoconf-2.59               p5-gettext-1.03
gnu-automake-1.9.6              pango-1.8.2
gnu-libtool-1.5.18              pcre-6.2
gnutls-1.0.24_1                 perl-5.8.7
gtar-1.15.1_1                   pkgconfig-0.17.2
gtk-2.6.9                       png-1.2.8_2
gtk-engines2-2.6.4              popt-1.7
gucharmap-gnome-1.4.3_1         portaudio-18.1_2
guile-1.6.5                     postgresql-client-7.4.8
help2man-1.35.1                 postgresql-libpqxx-2.5.5
hicolor-icon-theme-0.5          python-2.4.1_3
howl-1.0.0                      qt-3.3.4
imake-6.8.2                     rsync-2.6.6
intltool-0.34.1                 samba-libsmbclient-3.0.14a_2
jackit-0.99.0                   scrollkeeper-0.3.14_1,1
jasper-1.701.0                  sdocbook-xml-4.1.2.5_2
jpeg-6b_3                       shared-mime-info-0.16_1
kdeadmin-3.4.2                  startup-notification-0.8_1
kdeartwork-3.4.2                tiff-3.7.3
kdebase-3.4.2_2                 unzip-5.52_2
kdebase-kompmgr-3.4.2           wv2-0.2.2_1
kdegames-3.4.2_1                xmlcatmgr-2.2
kdehier-1.0_6                   xorg-clients-6.8.2
kdelibs-3.4.2_1                 xorg-documents-6.8.2
koffice-1.4.1,1                 xorg-fonts-100dpi-6.8.2
lcms-1.14,1                     xorg-fonts-75dpi-6.8.2
libIDL-0.8.6                    xorg-fonts-encodings-6.8.2
libXft-2.1.7                    xorg-fonts-miscbitmaps-6.8.2
libart_lgpl2-2.3.17             xorg-fonts-truetype-6.8.2
libaudiofile-0.2.6              xorg-libraries-6.8.2
libbonobo-2.10.0                xorg-manpages-6.8.2
libbonoboui-2.10.1              xorg-server-6.8.2_6
libcroco-0.6.0_1                xterm-203
root at whiskey#
------------------------------------ end 
------------------------------------





More information about the freebsd-ports mailing list