bpm problem

Michael Hopkins michael.hopkins at hopkins-research.com
Tue Oct 11 03:05:55 PDT 2005

On 11/10/05 03:53, "Adam Weinberger" <adamw at FreeBSD.org> wrote:

> Michael Hopkins wrote:
>> Hi all
>> I have been enjoying the use of bpm for some time now as my way of
>> navigating the ports collection on FreeBSD.
>> For some reason today it crashed with a core dump about 3/4 of the way
>> through updating its' database when I first ran it.  This happened several
>> times in a row, even after a reboot, so I suspected the ports database may
>> have got corrupted and did a 'pkgdb -F' and a 'cd /usr/ports/; make
>> fetchindex' but still no joy with bpm.  I have not made any changes to the
>> system recently and I'm on AMD64 FreeBSD 5.4-RELEASE-p7 #2
>> Does anyone have any ideas that would help get it running again? Maybe it
>> has a database somewhere that can be renovated.  Alternatively, are there
>> any other ports that offer a GUI interface for working with ports?
>> Many thanks
>> Michael
> Michael -
> Seth, the maintainer of sysutils/bpm, is a really good guy who sometimes
> just needs a kick in the behind to fix bpm-related problems. I'm sure
> that if you send him an email with a more detailed report and a
> backtrace of the core dump, he'll be very responsive in fixing the problem.
> One problem with bpm is that whenever the INDEX structure changes, bpm's
> code needs to be updated accordingly.
> # Adam
Hi Adam

Yes I did mail him and he responded quickly. However, this is what happened


Thanks for the quick reply Seth.

I just discovered the command 'portsdb -uU' which is what I thought I was
doing when I ran 'pkgdb -F' but obviously not!

Output was this:

Updating the ports index ... Generating INDEX.tmp - please
wait.."/usr/ports/Mk/bsd.port.mk", line 2890: warning: duplicate script for
target "checksum" ignored
Warning: Duplicate INDEX entry: freeciv-gtk2-2.0.2
Warning: Duplicate INDEX entry: cvsup-without-gui-16.1h_2
[Updating the portsdb <format:bdb1_btree> in /usr/ports ... - 13334 port
entries found 
..12000.........13000... ..... done]

And now bpm is working fine again. Cool!




He noted this in his reply.

I have since realised that it has 'lost track' of some ports that I know are
installed - whether this is bpm itself or the use of 'portsdb -uU' I don't
know, but it's not a big problem for me.



        _/    _/   _/_/_/             Hopkins Research Ltd
       _/    _/   _/    _/
      _/_/_/_/   _/_/_/          http://www.hopkins-research.com/
     _/    _/   _/   _/
    _/    _/   _/     _/               'touch the future'

More information about the freebsd-ports mailing list