Problems compiling rdesktop 1.4.1

Andy Newman an at
Tue May 17 00:48:23 PDT 2005

On Tue, May 17, 2005 at 09:20:20AM +0200, Ralf Folkerts wrote:
> Am Montag, den 16.05.2005, 11:12 -0700 schrieb David O'Brien:
> Hi David,
> I also have a Problem here :-( I just forced a re-installation of
> libiconv (I also have 1.9.2_1) - but that didn't help. However, the
> "configure" did detect that iconv is installed...
> Do you have any hint?

I built rdesktop manually earlier today.  I haven't tried the port so
please excuse any thing that's been gone over before or doesn't
apply to the port.  It appears rdesktop's configure isn't picking
up that iconv.h is in /usr/local/include.  Running configure with
CPPFLAGS set to look there for headers fixed it, i.e.

    $ CPPFLAGS=-I/usr/local/include ./configure ...

Note that without CPPFLAGS set like so configure reports,

    checking iconv.h usability... no
    checking iconv.h presence... no
    checking for iconv... yes

Looking at the code they're using two macros to control iconv
related things, HAVE_ICONV and HAVE_ICONV_H. The check for
HAVE_ICONV_H in the autoconf configure input doesn't appear
to use the setting of the --with-libiconv-prefix switch to
configure so needs the CPPFLAGS setting to look in /usr/local/include
and set the HAVE_ICONV_H.


More information about the freebsd-ports mailing list